当前位置: 首页 > >

Python安装配置OpenGL环境

发布时间:

最*学*计算机图形学,需要使用OpenGL,踩了很多雷,最后终于成功了,总结了一下教程和一些踩雷心得


环境:win10_64位系统、PyCharm(本人使用的是python3.8版本)
错误安装如下(错误演示我使用的是python3.6版本)

打开PyCharm,如下图打开设置



在project untitled中打开python interpreter,如下图所示



有的教程是让你在这里直接搜索OpenGL进行安装,然而这里只能安装32位,所以会导致代码是不报错了,可是运行便会报错(glut错误),如下所示


? ? ? ? ? ?


下面是正确安装方法(python3.8演示)

我们不能在PyCharm上直接安装OpenGL,需要在官网上进行下载


链接:https://www.lfd.uci.edu/~gohlke/pythonlibs/


进入后一直向下找,找到PyOpenGL,我的是python3.8版本,就选择下载箭头指的两个文件(cp38:意思就是python3.8版本;amd64:意思就是64位操作系统)


根据自己的版本进行下载



我的是在直接下载到了C盘中,如下所示



这两个.whl文件需要使用cmd命令窗口进行命令安装,它会直接安装到你的对应版本的库文件中




pip install PyOpenGL-3.1.5-cp38-cp38-win_amd64.whl

pip install PyOpenGL_accelerate-3.1.5-cp38-cp38-win_amd64.whl

安装成功后,去PyCharm的设置去查看库,如下所示



这里有个点要注意一下,本人在这里踩了大雷,因为我之前的PyCharm使用的是python3.6版本,所以导致我安装完之后,无法使用,但当我下载了3.6版本的时候,发现系统提示我无法安装,应该是因为我有3.8版本,导致我3.6无法正常去安装,所以这里就需要切换到python3.8的对应路径,如何就可以正常使用了。


如下图,找到自己的python3.8文件夹,然后找到里面的python.exe文件,然后将它的路径添加的下图红框中的地方去,就可以成功导入你python3.8的库了,然后在检查自己库中是否存在PyOpenGL和PyOpenGL-accelerate



代码测试

from OpenGL.GL import *
from OpenGL.GLU import *
from OpenGL.GLUT import *


def Draw():
glClear(GL_COLOR_BUFFER_BIT)
glRotatef(0.5, 0, 1, 0)
glutWireTeapot(0.5)
glFlush()


glutInit()
glutInitDisplayMode(GLUT_SINGLE | GLUT_RGBA)
glutInitWindowSize(400, 400)
glutCreateWindow("test")
glutDisplayFunc(Draw)
glutIdleFunc(Draw)
glutMainLoop()

测试结果

旋转的立体水壶



?


?


参考链接:https://blog.csdn.net/feilong_csdn/article/details/61421002


?


?


?


?


?



友情链接: